0 points
Submitted by Linda Liukas
over 9 years

Problems with font-size? Check your zoom

This exercise is particularly sensitive to browser zoom settings. If you’re having trouble with your font sizes, reset your browser’s zoom by pressing Cmd-0 or Ctrl-0.

Answer 513bd0a4ed5846ead1003795

21 votes

Permalink

Try and remove all the opening paragraph tags

because that’s how I managed to complete that exercise after trying zoom in zoom out like everyone else says.Hope it works.

points
Submitted by jon
over 9 years

56 comments

satishedupuganti over 9 years

thanksss

Projectshadow over 9 years

That’s exactly what needed to be done. Thanks.

Lisa Archer over 9 years

Yes!!!! Thank you, It even looks like it makes more sense as well! Cheers!

hellomynameisnathan over 9 years

didn’t work

taliak over 9 years

THANKYOU!!

bootow over 9 years

Thank you ,Worked for me

jimmypage over 9 years

Thank you! It worked, but in the ‘result’ page it was definitely not correct. But yeah, it might be a bug from the sistem. :D

Rhys Lima over 9 years

thank you worked for me

Cláudia Monteiro over 9 years

thanks, it worked!

jackcote19 over 9 years

thanks it worked

44yu Y over 9 years

Thanks a lot! it’s OK now

Bhushan over 9 years

Its not working !!!!!!

Denise Walker over 9 years

That’s so weird. yeah it doesn’t show up at all in results page but says it’s correct when I submit it.

kavern over 9 years

ahh….it works.thanks a lot.

Gregory McFarland over 9 years

This worked for me, but I’m not sure if this is a browser issue or not, but hey we all have to get pass this lesson somehow.

Ms Dracker over 9 years

Removing the opening paragraph tags definitely allows you to pass the exercise however the expected output is completely thrown off without the use of them.

Mohammed Uddin over 9 years

Helped me so much =[] Thanks!

akaWojeck over 9 years

yep this worked for me too. thank you it was so frustrating lol

xingkong over 9 years

It’s so amazing ! Thanks !

Matt Reilly over 9 years

perfect, thanks

Carmen Zullo over 9 years

awesome it worked

Jonathan Kimray over 9 years

Removing the tags did it for me, as well. Weird..

Mardoko over 9 years

Nice it works for me too, thanks Jon

Rahat Malik over 9 years

Worked for me. Codeacademy please have a look at this exercise and try to fix this bug. Its incredibly annoying and throws you completely off rhythm. Btw, I tried the whole ctrl-0 thing and didn’t work. Using Firefox.

Lily over 9 years

Works great. Thanks!

Skynet over 9 years

@jon, thank you man. that was awesomely the weirdest fix ever!!! thank you again. I used on font-family and it worked!!

Noah M. over 9 years

Thank you sir. You deserve a cookie.

anonymous over 9 years

thanks alot it defintiely worked. its just weird because the results were thrown off

Orion Rodriguez over 9 years

Haha, You’re brilliant! I was trying things out for awhile now! Like 3 minutes really when i decided to come here, Thank you so much.

Izzie McKenzie over 9 years

Thanks it really works!

Lynn Tieu over 9 years

Paragraph tags? Please explain, I’m not the smartest at coding, sorry :(

Ethan Leyden over 9 years

Awesome!!

Izzie McKenzie over 9 years

@Lynn Teiu paragraph tags-

BodangJangles over 9 years

Thank you I was having trouble getting passed that lesson. Your solution defiantly worked.

Arnold Certa over 9 years

Thanks

Alexander over 9 years

Thanks u !

rohith 2020 over 9 years

thanks it works>>>>>>>>>>>

Daniel Takagi about 9 years

Worked - thanks. I removed only the <li and <p part of the tags the rest left alone.

Alvin- about 9 years

thank you! it works

Michelle Harper about 9 years

thank you!

lmlotw about 9 years

thank you! it works!

jacky1122 about 9 years

i have to zoom out my chrome to 150% to make the test work

catcuts about 9 years

Me, too.

Ali Coulibaly about 9 years

Thank you , I also had to remove all the opening paragraph tags .

Daniel about 9 years

Awesome, Thanks!

Johnnyno9 about 9 years

Removed all the tags and the first 2 work and not the 40px one

Alan Curiel about 9 years

thanks very helpful

骆天义 about 9 years

it really works :) AWESOME!

Thanis Sky almost 9 years

wowwww soooo thnks

ricanpeacan almost 9 years

It really worked! Thanks so much!

godblesshk almost 9 years

Thanks so much! it worked! it’s a bug i think!

flip flip almost 9 years

I pushed control-0 and nothing happens where do i go to change it or press the button?

cheesek over 8 years

the whole page zooms should be 150%

Thanks so much I thought I was doing something wrong.

junjielee over 8 years

thanks so much

yaohuimo about 8 years

there still have problem.

Answer 513dfc755b0073afe5007b43

17 votes

Permalink

some browser set the lowest font-size to 12px,so you write 8px and the browser reset it to 12px ,so you can not pass it , so just change your browser settings , my browser is chrome ,i change it, then i pass it

points
Submitted by 张鹏
over 9 years

25 comments

dengyifan over 9 years

very useful! I did what you`ve told and get pass,great! Thanks a lot!

张鹏 over 9 years

are you chinese?

Ankur Sharma over 9 years

how can i reset the browser settings in chrome ??

Ziyi over 9 years

it’s useful! Thx!

Robet over 9 years

I’m pass it!thx!

Gareth over 9 years

My chrome makes my minimum size the standard for all the others any help?

ZiNtOz over 9 years

How to change the browser settings?

Yu Huibin over 9 years

If you use chorme, you can set it at the advance setting–>font–>the min font

Ziegler over 9 years

very useful! thx!

zoeyfan about 9 years

Useful! Thx!

Shenhong about 9 years

thanks a lot~

Shengfen about 9 years

thanks a lot. My problem was like yours. The lowest font-size is 12px, after I set it to 10px the problem was solved.

Zoe about 9 years

Thanks a lot, the font size setting is in the Web Content.

[email protected] about 9 years

it works!

jiajias about 9 years

It work!Thanks!

Enes about 9 years

Passed !!!

Karra about 9 years

Thanks!

yyymmm923 about 9 years

Awesome, Thanks a lot!

Michael Huang about 9 years

Thanks! I passed!

Chen Chen about 9 years

Thanks!

[email protected] about 9 years

and how to change it? just ctrl+0?does it work?

骆天义 about 9 years

same question here

widefni about 9 years

Thank you!

MortalKombat about 9 years

I pressed Ctrl + 0 and nothing happened with the font. I’m not using Google Chrome.

yaohuimo about 8 years

I’m using google chrome ,but it can’t work with your help .

Answer 513fe8e8e18a571aa90015b5

7 votes

Permalink

i have the same problem, i tried all the suggestions.. but doesn t work still says that the size it’s not right! :(

points
Submitted by Peggy Be
over 9 years

3 comments

Martin about 9 years

try this)

style = “font-size: 40px”>

advanced text size in chrome text size 8 courier new standard text size 40 times new roman

Marcio Angelo over 8 years

Thanks!

Valentina Filipova almost 8 years

thank you.

Answer 51449b5a006a282ef60062a6

5 votes

Permalink

points
Submitted by olegcieslik
over 9 years

5 comments

Jay Lee over 9 years

its amazing to use p> p style… to get your point ~~

Isolate13 about 9 years

this works - well done!

Guilherme about 9 years

thanksss!!

[email protected] about 9 years

may i ask how to pass it?my browser is chrome 27,and almost every question about the pixel can`t be passed

THANKS! I have a few questions… 1st, how did you find that out? 2nd, Why does that work and how does it work? 3rd, Why does everything look super small?

Answer 51a51f6de08dae33a7000a57

3 votes

Permalink

Hey, try this

irrespective of which ever browser you use just change the minimum font size form settings.

In my case its chrome(settings>show advanced settings>web content>customize fonts> minimum font size to 10px).

This works!!!

points
Submitted by KiranSK
about 9 years

3 comments

zmoron almost 9 years

this works. i followed the suggestion here and sure enough i passed the exercise.

Viora Lee almost 9 years

It works!!!

Louis Heard almost 9 years

Having a problem still! This is what the error states “Oops, try again! It looks like your first

  • ‘s font-size is 16px instead of 16px.”
  • Answer 51666678dd5582f791002679

    2 votes

    Permalink

    i have the same problem, i tried all the suggestions.. but doesn t work still says that the size it’s not right! I use the chorme 27.0.1438.7, and I use zoom 150%,then I pass it. I think it’s a bug.

    points
    Submitted by Mingtu Chen
    about 9 years

    3 comments

    Skynet about 9 years

    @Mingtu chen, no its not a bug. Our browswer settings affects font sizes :(

    Zero Yeung about 9 years

    it works using zoom 150% with Chrome. Thanks.

    Wael Albassam about 9 years

    Thanks ,it worked for me.

    Answer 514e9d2036e034b8890006f9

    1 vote

    Permalink

    I tried everything I can’t seem to get past it. Code Academy is onto something really great here - I hope they fix the little things.

    points
    Submitted by Theo Grobler
    over 9 years

    1 comments

    mamady about 9 years

    I am having the same problem, using google chrome, I am frustrated >:-0

    Answer 513d35683974ea8d27003b4d

    0 votes

    Permalink

    If any of you are using a Mac, in Safari’s preferences there is an option under “Advanced” that says “Never use font sizes smaller than” with a drop-down box. You must disable this so the font is able to be smaller that 9 (which is the smallest allowable setting). I struggled with this lesson for half an hour before I somehow remembered this setting.

    points
    Submitted by Jeff Knott
    over 9 years

    2 comments

    Peggy Be over 9 years

    i did it and doesnt work.. i tried to do cmd-0 and doesnt’t work either!

    Tim Close over 9 years

    Perfect - Thanks!!

    Answer 513d7668c0d160387a00502c

    0 votes

    Permalink

    I encountered this issue and I I have a question about this. Is this a “bug” in the HTML interface? Is i a browser issue? or is it something odd about the HTML interface used on this site? It seems logical that the HTML font size attribute shouldn’t be at all affected by what my zoom level is at in my browser. Does anyone know WHY this issue comes up?

    points
    Submitted by Jeff Greenlee
    over 9 years

    Answer 513e530c7540a9fa3e0005b4

    0 votes

    Permalink

    I had the same problem, but then again I checked all the solutions (in my browser both Firefox and Chrome, under settings I checked my minimal font size, I zoomed and re-zoomed and still nothing. Then I saw the post Linda gave actually the right answer for exercise 2.3 for the colour (I compared the whole code with mine and, at first didn’t saw any difference but when I checked line by line and sign by sign I saw the difference and this actual difference in the code helped me pass all other exercise. So once more, check your code line by line and sign by sign. For now I will not tell you were was my mistake - of course I am not guarantee that this was the solution why I passed but it might be. But for me read the post and check with my codes gave me the answer - and this time the correct one.

    points
    Submitted by Why Not
    over 9 years

    Answer 513f3ccee222b8b99e0055b5

    0 votes

    Permalink

    I ended up just skipping this section, the font size worked the first time ..I had a colon(:)instead of (-), then the next section, which had no errors would not let me pass. I have tried all the suggestions and even noticed, when using chrome, if you zoom in or out, and submit, it tells you the size of the font. If you zoom smaller (the size gets bigger) and vice versa but never hits on the mark. To save my sanity, I moved to the next section after 20 minutes.

    points
    Submitted by Trecia Arlette
    over 9 years

    1 comments

    Trecia Arlette over 9 years

    copy and paste from the recap—remove the color code, then change the font sizes and font type..walahh!

    Answer 51405de971e171d3af003fe2

    0 votes

    Permalink

    (the browser for me : chrome)

    first go to your browser’s advanced settings and then choose the smallest size of fonts then, use a space between your (:) and your number (16px) and then try some other sizes around 16px! it’ll work. like this : (font-size: 17px) I did it , and it worked. I hope it’ll be helpful to you too bro.

    points
    Submitted by Mojtabaa
    over 9 years

    4 comments

    sheni over 9 years

    i TRIED THE ADVABCED SEETING OPTION AND DID AS U SAID BUT IT DOESN’T WORK FOR ME SADLY :(

    Rachael Ranney over 9 years

    Or me either.

    Mojtabaa over 9 years

    I know that’s not a logical way , sorry , I just wrote this in hope of a probable help…

    Heqing Wong over 9 years

    Thanks,I done it

    Answer 5144871ca1e7e0b0b6005abd

    0 votes

    Permalink

    I tried everything. 3 different browsers: chrome (my standard), safari, and firefox and I played games with all of the settings including the cmd zoom options and editing the advanced text settings in each browser and nothing helped. So one please message me when they have found a complete solution.

    points
    Submitted by Daniel Leiker
    over 9 years

    1 comments

    sheni over 9 years

    well just try by writing “font-size: 10px” instead of “fontsize: 10px”. It worked foe me :)

    Answer 51463baf5c73ab13b30009aa

    0 votes

    Permalink

    I tried all of these things and none of them worked. No matter what I tried, zoom, browser settings, different sizes close to the size called for in the exercise, etc. I kept getting the error “It looks like you used size 32 instead of 16”.

    Finally, I realized I used color= instead of color:

    Whoops! Hopefully my mistake will help someone else!

    points
    over 9 years

    Answer 514761fc8706f28320000ced

    0 votes

    Permalink

    OK, my results seem to be correct. However, it still says my first paragraph seems to have a font size of 9 instead of 10. Please help.

    points
    Submitted by Gevin Brown
    over 9 years

    Answer 514aa0f25052062ad3000fbb

    0 votes

    Permalink

    In addition to zoom, the exercise is also sensitive to minimum font sizes. Check your browser settings.

    points
    Submitted by Freelancer_
    over 9 years

    Answer 514b4415a386d465780007e5

    0 votes

    Permalink

    try “font-size” instead of “fontsize”. It worked for me finally :)

    points
    Submitted by sheni
    over 9 years

    2 comments

    Pooja Khandelwal about 9 years

    thnxs

    Ulanbek about 9 years

    thanks

    Answer 51506af73f614f388c0008f7

    0 votes

    Permalink

    The correct way of doing this is to remove the original bracketed p from the front and make sure that the closing one after the code for the size is removed.

    points
    Submitted by Curtis Dickson
    over 9 years

    2 comments

    danibentley about 9 years

    Got it. This is the correct way.

    danibentley about 9 years

    Thanks :)

    Answer 5150f88be1b1891a5a0011ca

    0 votes

    Permalink

    This is what worked for me after trying to change all the broser font settings with no success. Thank you Curtis. It was your comment that helped me realize what my mistake was. You don’t need

    . <p style … > replaces it.

    points
    Submitted by Rob Olejniczak
    over 9 years

    Answer 5168f33f43cf39a6b3000320

    0 votes

    Permalink

    I could not pass that,it always says that:”Oops, try again! Did you set the first paragraph’s font-size to 10px? It looks like it’s 16px. (If you’re getting a weird decimal font size, check the Hint.)”

    points
    Submitted by tttmmiao
    about 9 years

    Answer 51a77245cd42c097d90065b0

    0 votes

    Permalink

    i got the stupid way to solve this problem..——>use safari。。。

    points
    Submitted by [email protected]
    about 9 years

    Answer 51c226f07c82cae770006ae8

    0 votes

    Permalink

    Hi Guys,

    This is what worked for me with NO browser changes. (Running Firefox) Hope it helps…

         <p style="font-size: 10px;">Some text for you to make tiny!</p>
        <p style="font-size: 20px;"> Some text for you to make normal size!</p>
        <p style="font-size: 40px;"> Some text for you to make super big!</p>
    points
    Submitted by ChrisBradley1985
    about 9 years

    1 comments

    godblesshk almost 9 years

    ask the same question!! help!

    Answer 51dc152a631fe9bf6c00a0b0

    0 votes

    Permalink

    points
    Submitted by haasher
    almost 9 years

    Answer 5383391c282ae3ae89007880

    0 votes

    Permalink

    First, I follow the prompts to change the browser font settings , but there are still problems. So carefully checked the discovery to write a

    , I hope for your help.

    points
    Submitted by yaohuimo
    about 8 years

    Answer 547c748f52f863441000c3bd

    0 votes

    Permalink

    Blockquote

    points
    Submitted by Zabolotskih Dmitriy
    over 7 years

    Answer 513c164327ffd87763004e73

    -4 votes

    Permalink

    change 8px to another(e.p 12px),anyothers can also be ok,it wil suggest something. then change it back to 8px ,that will be passed,i just tried

    points
    Submitted by microcai
    over 9 years

    2 comments

    Projectshadow over 9 years

    I just tried that myself, and it kept telling me the same thing. I think half of these lessons are glitched in some way.

    hellomynameisnathan over 9 years

    didn’t work