This forum is now read-only. Please use our new forums at discuss.codecademy.com.

CSS: An Overview Forum

View Course » View Exercise

183 points
58d1726b92f407a52e000370_444294279
Submitted by
PottsTower
almost 2 years ago

Error Codes on 26/26

The lesson had told me to make add a link on my HTML page, and I did. I did it exactly as they told me to, but it kept giving me an error code saying:
"Oops, try again. Did you remember to put some link text between your tags? You can't leave them empty!"
Here's my html:

<!DOCTYPE html>
<html>
    <head>
        <title>Result</title>
    </head>
    <body>
        <link type="text/css" rel="stylesheet" href="stylesheet.css"/>
        <h1>Coding</h1>
        <p>Click the link to go to a great website to learn code.</p>
        <a href="http://www.codecademy.com/learn">Codecademy</a>
        <img src="https://d1qb2nb5cznatu.cloudfront.net/startups/i/57028-75249c08760cc9b8331013724066c538-medium_jpg.jpg?buster=1407971510"/>
    </body>
</html>

I'm very confused, because the text shows up on the Results page, and the link works, but I'm still getting an error message.
Any help you can give would be appreciated. Thanks!


1 vote

permalink

<link> is not valid in the <body> element, as it is metadata intended to load in the <head> element.

7734 points
58dc9a7fdd1edef33e000457_828040695
Submitted by
Roy
almost 2 years ago


-2 votes

permalink

check here how to format your code. Your code is currently not visible. if you update your question please leave a comment so i get a notification.
If you put your code i a comment, i am going to ask you to redo it, and use proper format.

Can you post all of your html? You can try to refresh/switch browser if you think you hit a glitch, if this doesn't work, please post code

2410 points
5671826195e378c47d000782_659060817
Submitted by
stetim94
almost 2 years ago

4 Comments

58d1726b92f407a52e000370_444294279 PottsTower almost 2 years ago

Ok, I updated it. Thanks for telling me about that.

5671826195e378c47d000782_659060817 stetim94 almost 2 years ago

works fine, make sure the zoom is 100%. try refreshing/switching browser

58d1726b92f407a52e000370_444294279 PottsTower almost 2 years ago

I tried changing the browser and it worked. Thanks for your help!

5671826195e378c47d000782_659060817 stetim94 almost 2 years ago

little glitch (caused by cached behavior), switching browser solves this problem